We noticed that you're using an unsupported browser. The TripAdvisor website may not display properly.We support the following browsers:
Windows: Internet Explorer, Mozilla Firefox, Google Chrome. Mac: Safari.

google fi in Aruba

Phoenix
Level Contributor
7 posts
7 reviews
google fi in Aruba

Just got back from Aruba and contacted Google Fi. They do have services.

This is their response:

Hi Francis,

Thank you for contacting Project Fi Support. Hope you’re doing well!

I've checked and confirm you that we have coverage in Aruba. I request you to perform below troubleshooting steps.

A.

Open the Project Fi app.

Scroll to "Your Plan" and click "Manage Plan"

Scroll to "International Features"

Turn on "Service outside the US" toggle.

B. Wi-Fi calling is only enabled when users turn data off

C.

Open the dialer

Click on the 3 dots on the top right hand corner

Click on 'Settings''

Click on 'Calls'

Click on 'Configure Wi-Fi calling'

Enable Wi-Fi calling

D. Turn airplane mode on then off (turn on for 5 seconds, then turn off).

E. Restart phone.

F. Dial *#*#FIROAM#*#* (same as *#*#347626#*#*). OR,

For Android 7.0: Open phone Settings Settings and then More and then Cellular Networks and then Network Operators and thenSearch networks.

For Android 8.0+: Open phone Settings Settings and then Network and Internet and then Mobile Network and thenNetwork Operators and then Search networks.

Let the network list load. Then, select one network at a time until the phone has a successful connection.

G. Turn on data roaming

Open your phone's Settings app Settings.

Tap Network & Internet.

Tap Mobile Network.

Turn on Data roaming.

Open the Project Fi app Project Fi or website.

In the Account tab, go to Your Plan.

Make sure both Service outside the U.S. AND Calls to non-U.S. numbers are turned On.

If the problem persists after trying the above steps, please use these dialer codes.

Dial *#*#FITMO#*#* (same as *#*#34866#*#* — Manually switch to T-Mobile for 2 hours.) Auto-switching re-enables automatically after 2 hours.

Dial *#*#FIAUTO#*#* (same as *#*#342886#*#* — Manually re-enables auto-switching.)

If the issue is still not resolved, please provide us below details; we'll get this forwarded to a specialist.

What is the exact address you’re staying at? This is required by our partner carriers, so being as exact as possible helps expedite your resolution. If you cannot provide an exact address, please provide the cross streets, the city, and state where you’re currently at.

When was the date you arrived in the country?


Did talk, text, and data work when you arrived in the country? What works, and what doesn’t? When did it stop working?


How often does this happen? Does it connect temporarily and disconnect, does it never connect, or does it connect, but not register data?


How long will you be in this country?


What is the time and date of the most recent failure?


Do you see any errors? If so, can you take a screenshot?

If you're trying to register while on a 4G or 4G LTE network, have you tried to register on 2G only? This can be found in Settings > More > Cellular Networks.

How many times have you rebooted your phone? Have you waited about 5 minutes before the next attempt?

Can you include a screenshot of the networks you see when you put in *#*#FIROAM#*#* (or go to Settings > More > Cellular Networks >) and see the list of partner carriers there?


Can you manually connect to each of the partner networks and see if one of them has all three services (talk, text, and data) working? (If the first attempt is not successful please try again, up to 3 times).

If you have any other queries or concerns, please feel free to reply to the email or contact us. Wish you a great day!

Thanks,

Sami

The Project Fi Support Team

3 replies to this topic
Nutts Corner...
Level Contributor
1,326 posts
102 reviews
1. Re: google fi in Aruba

Thanks for letting us know.

1 post
2. Re: google fi in Aruba

I am in Aruba now, and Google Fi is NOT supported here.

TN
Level Contributor
84 posts
10 reviews
3. Re: google fi in Aruba

TMI for my vacation!

Reply to: google fi in Aruba
Get notified by e-mail when a reply is posted